Nibiru VR Development Unity/Unreal SDK 我们在应用中添加蓝牙BLE代码,用于扫描iBeacon设备来获 ...

我们在应用中添加蓝牙BLE代码,用于扫描iBeacon设备来获取外界信息

云中漫步 Post time 2019-12-4 17:26 | Show all posts [Copy URL]
16 911
nibiru_studio_3_1_15_293 basic
现在蓝牙启动正常,扫描函数也正常启动,但是检测不到蓝牙信号
同样的代码在android手机需要给APP开启位置权限才能运行正常,眼镜里是否需要同样的操作,该怎么进行
Reply

Use magic Report

Post time 2019-12-4 17:19 | Show all posts
眼镜也是要赋予权限,你是动态申请权限的吗
Post time 2019-12-4 17:19 | Show all posts
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
    <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" />
    <uses-permission android:name="android.permission.INTERNET"/>
    <uses-permission android:name="android.permission.CAMERA" />
    <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
    <uses-permission android:name="android.permission.BLUETOOTH" />
    <uses-permission android:name="android.permission.BLUETOOTH_ADMIN" />
    <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />
在androidmanifest里面申请了
Post time 2019-12-4 17:20 | Show all posts
targetSdkVersion 和机器Android版本是多少
Post time 2019-12-4 17:21 | Show all posts
android {
    compileSdkVersion 29
    buildToolsVersion "29.0.0"
    defaultConfig {
        applicationId "com.besct.esspoc"
        minSdkVersion 26
        targetSdkVersion 29
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
    }
Post time 2019-12-4 17:22 | Show all posts
机器的OS是这几天刚从贵公司发过来的,应该是最新的
系统版本 3.70.006

Post time 2019-12-4 17:22 | Show all posts
targetSdkVersion 降到19试试
Post time 2019-12-4 17:25 | Show all posts
minSdkVersion 21可以使用,我用的代码有些函数最低需要21的版本调用 setSkyboxName 切换天空盒多次后,会黑屏,关闭软件再打开也不管用,只能重启眼镜黑屏时中间的白色小圆点还在,也能移动

Post time 2019-12-4 17:26 | Show all posts
其他控件也没有了吗
Post time 2019-12-4 17:26 | Show all posts
我就加了label控件,也没有了,不知道是看不见还是其它的情况
12Next
Return to forum
You have to log in before you can reply Login | Register

Points Rules

!fastreply! Top !return_list!